[an error occurred while processing this directive]

JMRI Guide Matériel: Chubb C/MRI

Matériel Supporté

  • Chubb C/MRI USIC
  • Chubb C/MRI SMINI
  • Chubb C/MRI SUSIC

A ce jour, les interfaces directement connectées IBEC et UBEC ne sont pas pris en charge.

Table des Matières

La documentation ci-dessous explique comment JMRI peut être utilisé avec C/MRI, et comment démarrer avec la connexion d'un système C/MRI à JMRI. Il suppose une base de connaissance de JMRI (tel que documenté sur ce site web JMRI), et une certaine familiarité avec C/MRI. Il est fortement recommandé que les utilisateurs aient accès au Manuel de l'utilisateur C/MRI, la version 3.0 de Bruce Chubb car il contient une documentation détaillée sur le matériel, qui n'est pas disponible ailleurs. Puisque vous n'avez pas besoin de programmer votre ordinateur si vous utilisez JMRI avec votre système C/MRI, vous pouvez sauter sur les détails de la programmation informatique lors de la consultation du Manuel de l'utilisateur C/MRI . La documentation ci-dessous est divisée en sections; cliquer pour un accès facile à une section ci-dessous:

Introduction à C/MRI sur JMRI

C/MRI est un système d'entrées/sorties numériques qui peuvent être utilisées pour connecter un ordinateur à un système C/MRI pour réseau ferroviaire, permettant à l'ordinateur de surveiller et de contrîler les différents éléments du réseau. Le SUSIC (Super Universal Serial Interface Card) est la carte contrîleur pour un grand système numérique E/S supportant, par l'intermédiaire d'une carte mère, jusqu'à 64 cartes d'entrées ou de sorties numériques , soit avec 24 ou 32 lignes d'entrée ou de sortie par carte. L'USIC est une ancienne version de la SUSIC. La carte Smini (Super Mini-noeud) est un noeud série autonome offrant un nombre fixe de 24 lignes d'entrée et 48 lignes de sortie. Un nombre d'autres cartes d'interface sont disponibles dans le cadre de la C/MRI, mais elles doivent être connectées à votre ordinateur via une Smini, une SUSIC, ou une USIC. Par exemple, une carte détecteur d'occupation DCCOD de C/MRI se connecte à la ligne d'entrée d'une Smini (ou SUSIC ou USIC). Les réseaux qui utilisent C/MRI ont généralement plusieurs Smini situées à différents endroits sur le réseau , et peut-être une ou deux SUSIC situées sur le panneaux CTC.

C/MRI n'est pas un système de contrîle des trains. Vous pouvez exécuter C/MRI avec un système de contrîle de train DCC (tels que, Digitrax, Lenz, ou NCE) ou avec un système DC de contrîle des trains Et vous pouvez utiliser avec votre JMRI avec le système C/MRI si vous utilisez DCC ou DC pour contrîler les trains. Si vous contrîlez vos trains avec un système qui prend en charge JMRI, vous pouvez connecter votre système C/MRI et votre système de contrîle de train à JMRI simultanément, chacun avec sa propre ligne série d'entrée dans votre ordinateur. La plupart des utilisateurs qui utilisent C/MRI exécutent JMRI ayant des liens avec à la fois leur C/MRI et leur système de contrîle des trains. Il y a de nombreux avantages à le faire. JMRI vous permet de "mélanger et faire correspondre" comment vous contrîler et surveiller les choses sur votre réseau. Par exemple, vous pouvez basculer votre aiguillage en utilisant des décodeurs statique sur votre système de contrîle des trains, et utiliser simultanément les entrées de C/MRI pour fournir une rétro signalisation de l'aiguillage vers JMRI. JMRI est conçu pour rendre les deux systèmes connectés compatibles.

Le Logiciel JMRI se compose d'une grande bibliothèque, divisé en 1) une partie spécifique, avec des sous-parties nombreuses, dont chacune communique avec un système matériel supporté, comme le système C/MRI, d'une manière spécifique , et 2) une partie indépendante du système où la plupart des caractéristiques de JMRI sont mises en oeuvre. Ainsi, par exemple, si l'utilisateur fait quelque chose (peut-être déterminer un itinéraire) pour pousser JMRI à basculer un aiguillage, l'action de l'utilisateur aura lieu dans la partie indépendante du système du logiciel, puis ce sera à JMRI d'envoyer la commande effective par la partie dépendante du système approprié pour le système de matériel de commande de l'aiguillage particulier à basculer. JMRI est conçu afin que les fonctionnalités soient mises en oeuvre dans la partie indépendante du système autant que possible, avec l'aide de sous-parties JMRI dépendantes du système que lorsque c'est vraiment nécessaire. L'accès aux fonctionnalités du système indépendant se fait via les menus JMRI principaux, tels que dans le menu Outils. L'accès aux fonctionnalités dépendant du système se fait via un menu intitulé pour le système matériel pris en charge; les fonctionnalités spécifiques C/MRI sont accessibles via le menu CMRI.

JMRI se présente aux utilisateurs via une application ayant plusieurs extrémités, chacune se concentrant sur un type d'utilisation, mais toutes basées sur la même bibliothèque. L'application populaire DecoderPro se concentre sur la programmation DCC des décodeurs, et n'est pas d'un grand d'intérêt pour C/MRI. D'autre part, PanelPro est l'application JMRI qui se concentre sur l'automatisation des réseaux, de la signalisation, et des panneaux CTC . PanelPro est l'application la plus souvent utilisée avec C/MRI, et est celle utilisée dans les exemples ci-dessous. Comme toutes applications de JMRI utilisent la même bibliothèque, il est possible de faire fonctionner un panneau depuis DecoderPro, ou même programmer un décodeur DCC depuis PanelPro. Ce n'est pas aussi facile que d'utiliser l'application ciblée.

Les Bibliothèques JMRI ont une prise en charge intégrée pour le matériel série C/MRI utilisant les USIC, SUSIC et Smini. Chaque Smini, USIC ou SUSIC est un noeud série capable de communiquer de façon autonome avec un ordinateur via un port série I/O. Plusieurs noeuds C/MRI peuvent être reliés entre eux en utilisant le protocole de communication RS485 dans un configuration en cascade, de sorte qu'une seule ligne série sur votre ordinateur est nécessaire. Pour que cela fonctionne, chaque noeud doit avoir une adresse différente, unique, réglée par les interrupteurs adresse sur la carte. Chaque noeud (USIC, SUSIC, ou Smini) a besoin de recevoir une chaîne d'initialisation avant de pouvoir communiquer avec un ordinateur. JMRI va automatiquement créer et transmettre la chaîne d'initialisation nécessaire lors de son démarrage, mais pour rendre cela possible, vous avez besoin de donner à JMRI les détails de votre matériel C/MRI mis en place. Nous faisons ce qui s'appelle la "configuration " de votre noeud C/MRI ( voir ci-dessous). Si vous mettez plusieurs noeuds C/MRI en guirlande, vous aurez probablement besoin d'une carte de conversion C/MRI RS232/RS485 entre le bus RS485 reliant les cartes et la ligne série RS232 pour se connecter à votre ordinateur. Si votre ordinateur ne dispose pas d'un port série RS232 (les ordinateurs les plus récents n'en sont pas munis), vous pouvez vous connecter à un port USB de l'ordinateur avec un câble adaptateur USB-série ( cliquez ici pour l'aide).

L'entrée C/MRI peut être utilisée comme "capteurs" JMRI, et la sortie C/MRI peut être pilotée comme des "aiguillages" ou des "lumières" JMRI ( voir ci-dessous). Notez que les entrées et sorties C/MRI sont parfois appelés "pins", parfois appelé "bits", et qu'on appelle parfois "lignes", tous sont des moyens équivalents de se référer à la même chose. C/MRI est un système de scrutation, ce qui signifie que la communication avec les noeuds C/MRI requièrent que l'ordinateur envoie périodiquement un message à chaque noeuds lui demandant de transmettre l'état de ses bits d'entrée. JMRI commence un sondage d'un noeud lorsque au moins un capteur a été mis en place pour se référer à un bit entrée de ce noeud. C'est cette action de scrutation qui maintient la LED sur votre adaptateur Smini clignotante (à un rythme élevé).

Bits d'Entrée et de Sortie C/MRI

JMRI considère les bits d'entrée de C/MRI comme des capteurs. Capteurs qui contribuent à JMRI pour les conditions du circuit - un bouton est enfoncé, un bloc est occupé, etc. Dans JMRI, vous vous référez à un bit d'entrée C/MRI (capteur) par son " nom système", CSnxxx, où nxxx est l'adresse du bit ( voir ci-dessous). Avant de pouvoir vous référer à un capteur dans JMRI, il doit être "créé". Un capteur peut être créé de diverses façons, y compris automatiquement. Tous les capteurs de JMRI qui ont été créés peuvent être consultés dans les Tableaux Capteurs JMRI, accessibles en sélectionnant Tableau Capteur dans les options du menu Outils. Un nouveau capteur peut être créé grâce au tableau capteur comme illustré ci-dessous. La création d'un capteur se référant à un bit d'entrée particulier de C/MRI , est appelée "affectation" du bit d'entrée. Chaque bit d'entrée ne peut être attribué qu'une seule fois, deux capteurs différents ne peuvent pas se référer au même bit d'entrée C/MRI. Un capteur est "actif" lorsque son bit d'entrée est à la masse et "inactifs" lorsque son bit d'entrée est hors tension. Donc quand vous voyez "Capteur", penser "bit d'entrée" ou "ligne d'entrée".

JMRI se réfère aux bits de sortie C/MRI comme les aiguillages ou les lumières. Les aiguillages et les lumières sont allumés/éteints par des interrupteurs que JMRI peut changer pour contrîler les choses sur votre réseau. Pour faire référence à un bit de sortie C/MRI comme un aiguillage, utilisez le nom système CTN, où Nxxx est l'adresse du bit de sortie ( voir ci-dessous). Pour faire référence à un bit de sortie C/MRI comme la lumière, l'utilisation CLnxxx, où Nxxx est l'adresse du bit de sortie ( voir ci-dessous). Les aiguillages et les lumières ont différentes méthodes de se référer aux sorties C/MRI au sein de JMRI. Chaque méthode a ses différentes options de contrîle. Toujours utiliser "Aiguillages" pour les sorties C/MRI utilisées pour la commande des aiguillages et pour les sorties C/MRI utilisées pour faire fonctionner les signaux. Pour des raisons historiques, les bits de sortie C/MRI utilisés pour commander l'aspect des signaux sont dénommés "aiguillages", même si les bits de sortie sont utilisés pour la commande de signaux lumineux Utilisé "lumières" pour faire référence aux bits de sortie C/MRI utilisés pour les feux du TCO , des feux dans un décor (éclairage de la structure, des lumières de la rue , etc), et à des fins spéciales où les options de contrîle pour les feux doivent répondre à vos besoins. Ainsi, lorsque vous consultez la section "aiguillage" ou "lumière" dans le cadre de C/MRI, pense que "bit de sortie" ou "ligne de sortie".

Avant de pouvoir se référer à un aiguillage ou une lumière à l'intérieur de JMRI, l'aiguillage ou la lumière doit être "créé". Un aiguillage peut être créé avec un certain nombre de moyens, y compris automatiquement. Tous les aiguillages JMRI qui ont été créés peuvent être vu dans le tableau aiguillage JMRI, accessible en sélectionnant Tableau Aiguillage dans le menu Outils. Un aiguillage peut être créé via le tableau aiguillage en cliquant sur "Ajouter" au bas de le tableau. Pareillement , une nouvelle lumière peut être créé par le tableau lumière de JMRI en cliquant sur "Ajouter" au bas de ce tableau. Le tableau lumière JMRI est accessible en sélectionnant Tableau Lumière dans le menu Outils. Tous les voyants JMRI qui ont été créés sont répertoriés dans le tableau lumière JMRI . La création d'un aiguillage ou d'un feu se réfère à un bit de sortie particulier de C/MRI ,qui est appelée "affectation" . Chaque lumière ou aiguillage est lié à une ligne de sortie spécifique via la partie adresse du nom système.

Un bit de sortie spécifique peut être considéré comme un aiguillage ou une lumière, mais pas les deux à la fois. Chaque bit de sortie ne peut être attribué qu'une seule fois. Quand un nouvel aiguillage ou une nouvelle lumière C/MRI est créé, JMRI contrîle que le bit de sortie spécifié est disponible pour l'affectation. Si la demande du bit de sortie C/MRI est en cours d'utilisation par un aiguillage ou une lumière, JMRI refusera de créer le nouvel aiguillage ou le nouvel éclairage. Notez que certains aiguillage C/MRI ont la possibilité d'utiliser deux bits de sortie, l'un adressée et le suivant ( voir ci-dessous), et que les deux bits de sortie doivent être non affectés pour la création réussie d'un nouvel aiguillage contrîlé par deux bits de sortie. La liste des affectations courantes C/MRI peut être obtenue en sélectionnant Liste affectations dans le menu C/MRI.

Mise en route avec un noeud Smini

Il est plus facile d'essayer JMRI avec une carte Smini, car il y a peu d'options à configurer pour le matériel C/MRI. Après avoir physiquement connecté Smini à votre ordinateur, suivez la procédure ci-dessous pour configurer votre Smini comme un noeude C/MRI, et de tester une entrée et un bit de sortie. (Cette procédure suppose que rien n'est raccordé à la broches d'entrée et de sortie de votre Smini, et que vous n'avez pas fait d'affectation pour ses bits.)
  1. Démarrez le programme PanelPro.
  2. Depuis le menu Modifier, sélectionnez Préférences ... et configurer:
    • Pour la connexion réseau sélectionnez "C/MRI".
    • pour le port série, sélectionnez le port matériel où votre matériel C/RMI est raccordé
    • Sélectionnez la vitesse de transmission que votre système C/MRI utilise.
    • Cliquez sur le bouton "Configurer le noeud C/MRI". Sur le nouveau panneau qui s'ouvre:
      • Entrez votre adresse de noeud de SMINI. (0 est généralement utilisé pour la première carte Smini, mais ce nombre est réglé par les commutateurs d'adresse sur votre carte SMINI.)
      • Sélectionnez "SMINI" pour le type de noeud.
      • Laissez DL à zéro.
      • Cliquez sur "Ajouter Noeud". Cliquez
      • "Terminé".
    • Retour sur le panneau "Préférences ...", cliquez sur "Enregistrer", et dire oui quand il vous demande si vous voulez quitter.
    • Redémarrez le programme. Vous devez affecter un bit d'entrée pour commencer la scrutation. Sélectionnez Tableau Capteur dans le menu Outils, et procéder:
        Cliquez
      • "Ajouter ..." au bas du tableau.
      • Dans la boîte de dialogue Ajouter un Nouveau Capteur:
        • Pour le nom système, entrez votre adresse CS1 si le Noeud SMIMI a été 0, ou encore entrer CSn001, où n est votre adresse du Noeud SMINI
        • Le nom système et le nom utilisateur apparaissent dans le tableau capteur.
        • Pour le nom utilisateur entrer "Test".
        • Cliquer "OK".
      • L'état de votre capteur dans le tableau capteur sera initialement "Inconnu", mais passera rapidement à "Inactif" lorsque la scrutation commence (en supposant que rien n'est raccordé à la broche d'entrée 1). La LED d'émission et de réception sur votre carte SMINI devrait maintenant clignoter, indiquant que l'ordinateur et lA SMINI dialoguent.
      • Pour vérifier que le bit d'entrée (capteur) que vous avez attribué est au travail, relier la broche d'entrée 1 à la borne de masse sur votre carte SMINI. Le capteur doit basculer à "Actif". L'état du capteur alterne entre "actif" et "inactif", selon que broche 1 est mise à la terre ou non.
      • Pour vérifier que tout fonctionne sur le cîté sortie, sélectionnez Commande Aiguillage dans le menu Outils. Lorsque les petites fenêtres de configuration de l'aiguillage s'ouvrent, procéder:
        • Pour l'aiguillage, entrez CT1 si votre adresse noeud était de 0, ou encore entrer CTn001, où n est votre adresse de noeud. (Ceci affecte 1 à votre bit de sortie de votre SMINI comme un un aiguillage.)
        • Cliquez sur "droit" ou "dévié" pour activer une ligne de sortie on et off.
            Si vous connectez un LED en série avec une résistance (la valeur en ohms dépend de la tension continue appliquée) à 1 bit de sortie, vous être en mesure de commuter la LED on et off en cliquant simplement sur "Droit "ou "Dévié " dans la fenêtre de commande de l'aiguillage. Notez que les bits de sortie SMINI peuvent être mis en place pour être soit "absorbeurs de courant" ou " générateurs de courants". (cela dépend de la façon dont votre SMINI est construite.) JMRI fonctionne de même, indépendamment du type de bits de sortie, mais le type de bits détermine la façon dont vous raccordez votre LED. Si vos sorties bits sont "récepteurs de courant" actuellement (le type le plus commun), relier le fil négatif de votre LED à la broche 1 de sortie, et la résistance entre le fil positif de la LED et une source de courant continu (généralement 3 à 12 volts). Si votre bit de sortie est en "générateur de courant", relier le fil positif de votre LED sur la broche 1, et relier la résistance entre le fil négatif de la LED et la masse actuelle.

Vous avez maintenant un noeud C/MRI configuré et fonctionnel. Vous pouvez ajouter plusieurs noeuds, en revenant au dialogue Configurer le noeud C/MRI ( voir ci-dessous). .

Débuter avec une USIC ou SUSIC

Après avoir connecté physiquement votre SUSIC (ou USIC) à votre ordinateur, suivez la procédure ci-dessous pour configurer votre SUSIC (ou USIC) en tant que noeud C/MRI , et de tester un bit d'entrée et un bit de sortie. La procédure suppose 1) que cette SUSIC est le premier noeud C/MRI connecté à votre ordinateur, 2) que rien n'est raccordé aux broches d'entrée de votre première carte d'entrée numérique, SUSIC, ou les broches de sortie de votre premiere SUSIC, 3) que vous n'avez pas donné d'affectations aux bits de votre SUSIC.

  1. Démarrez le programme PanelPro.
  2. Dans le menu Modification, sélectionnez Préférences ... et configurer:
    • Pour la connexion mise en page sélectionnez "C/MRI".
    • pour le port série, sélectionnez le port que votre matériel C/MRI utilise.
    • Cliquez sur le bouton "Configurer C/MRI". Sur le nouveau panneau qui s'ouvre:
      • Entrez votre adresse de noeud SUSIC. (0 est généralement utilisé pour le premier module SUSIC, mais ce nombre est réglé par les commutateurs d'adresse sur votre carte contrîleur SUSIC.)
      • Sélectionnez "USIC_SUSIC" pour le type de noeud
      • Laissez DL à zéro.
      • Sélectionnez "24-bit" ou "32-bit" pour la taille de carte, suivant si vous avez la carte 'originale DIN et DOUT 24-bit ou la plus récente 32-bit
      • Utilisez le tableau ci-dessous pour configurer vos cartes et dire à JMRI quelle carte a des cartes d'entrées et celle qui a des cartes de sorties. Pour chaque carte que vous avez installé, cliquez où il est dit "Sans carte" et sélectionnez "Carte d'Entrée" ou " carte de Sortie". Notez que les cartes d'entrée et de sortie peuvent être dans n'importe quel ordre, mais il ne faut pas d'espaces vides avant celle qui suit la dernière carte installée . (Il s'agit d'une exigence matériel de C/MRI .)
      • Cliquez sur "Ajouter Noeud"
      • Cliquez "Terminé"
    • Retour sur le panneau, "Préférences ... ", cliquez sur "Enregistrer", et dire oui quand il vous demande si vous voulez quitter.
  3. Redémarrez le programme. Vous devez affecter un bit d'entrée pour commencer la scrutation. Sélectionnez Tableau Capteur dans le menu Outils, et procéder:
    • Cliquez "Ajouter ..." au bas de le tableau.
    • Dans la boîte de dialogue Ajouter un Nouveau Capteur:
      • Pour le nom du système, entrez votre adresse CS1 si le noeud SUSIC a été 0, ou encore entrer CSn001, où n est votre adresse du noeud de SUSIC.
      • Pour entrer le nom utilisateur "Test".
      • Cliquez "OK".
    • Le nom du système et le nom d'utilisateur apparaîtront dans le tableau de capteur. L'état de votre capteur dans le tableau capteur sera initialement "Inconnu", mais passera rapidement à "inactif" lorsque la scrutation commence (en supposant que rien n'est raccordé à la broche d'entrée 1). La LED d'émission et de réception sur votre carte contrîleur SUSIC devrait maintenant clignoter, indiquant que l'ordinateur et la SUSIC dialoguent.
    • Pour vérifier que le bit d'entrée (capteur) que vous avez attribué est au travail, relier la broche 1 d'entrée (la première broche d'entrée sur la première carte d'entrée de votre SUSIC) pour diriger le courant à la masse.SUSIC La sonde doit passer à "Actif". L'état du capteur alterne entre "actif" et "Inactif", selon que broche 1 est mise à la masse ou non.
  4. Pour vérifier que tout fonctionne du cîté de la sortie, sélectionnez Commande Aiguillage dans le menu Outils. Lorsque les petites Fenêtre de configuration de l'aiguillage s'ouvrent, procéder:
    • Pour l'aiguillage, entrez CT1 si l'adresse de votre noeud SUSIC était 0, ou Sinon, indiquez CTn001, où n est votre adresse de noeud de SUSIC. Celle ci attribue 1 bit de sortie (la première ligne de sortie carte sur votre SUSIC) à l'aiguillage .
    • Cliquez sur "Direct"ou "Dévié" pour activer une ligne de sortie on et off.
    Si vous connectez une LED en série avec une résistance (la valeur en ohms dépend de la tension continue appliquée) à 1 bit de sortie, vous êtes en mesure de commuter la LED on et off en cliquant simplement sur "Direct "ou "Dévié" dans la fenêtre de contrîle de l'aiguillage. Sinon, vous pouvez utiliser un multimètre pour mesurer le courant sur un changement d'état du bit 1 comme il est on et off.

Vous avez maintenant un noeud C/MRI configuré et fonctionnel. Vous pouvez ajouter plusieurs noeuds, ou modifier la configuration de la carte DIN/ DOUT de ce noeud SUSIC, en revenant au dialogue de Configuration du noeuds C/MRI ( voir ci-dessous.

Gestions des Noeuds

Chaque SMINI, USIC ou SUSIC est appelé un "noeud". Avant d'utiliser C/MRI avec JMRI, vous devez dire à JMRI les noeuds que vous avez sur votre système et la configuration de chaque noeud. Lorsque vous sélectionnez C/MRI dans les Préférences de dialogue, un bouton "Configurer noeuds C/MRI" est affiché. Cliquez sur ce bouton pour faire apparaître une boîte de dialogue pour entrer des informations de configuration de noeud. Vous pouvez ajouter de nouveaux noeuds ou mettre à jour la configuration d'un noeud existant en revenant à la Préférence de dialogue ( Edition>Préférences ...) ou en sélectionnant Configurer noeuds C/MRI dans le menu CMRI. Assurez-vous de sauver vos préférences après avoir modifié la configuration de votre noeud. Utilisez la bouton fonction "Enregistrer" dans la fenêtre Préférences.

L'adresse d'un noeud est définie en utilisant l'adresse des commutateurs sur votre carte C/MRI. (adresses de noeud sont appelés UA dans les manuels C/MRI.) Les adresses de noeud doivent être unique pour chaque carte, mais ne doivent pas être séquentiels. L'adresse de noeud est utilisée dans le nom système JMRI pour référencer les bits d'entrée et de sortie appartenant à ce noeud (voir ci-dessous)

.

La configuration des noeuds C/MRI utilisant la boîte de dialogue de configuration est simple. Pour une SMINI, il suffit d'entrer l'adresse de la carte définie dans les commutateurs d'adresse sur le carte SMINI, sélectionnez SMINI pour le type de Noeud, et cliquez sur le bouton "Ajouter Noeud" . Pour une USIC ou SUSIC, entrez l'adresse du Noeud, sélectionnez USIC_SUSIC, cartes sélectionnez les cartes 24-bit ou 32-bit, puis dites à JMRI quelle type de carte occupe tel emplacement .

Pour chaque noeud, vous pouvez afficher une liste sommaire des bits C/MRI qui sont en utilisation et ceux qui sont disponibles. Sélectionnez Liste Liste d'Affectations dans le menu CMRI pour faire apparaître un dialogue Liste des Affectations C/MRI. Ensuite, sélectionnez le noeud intéressant dans la liste des noeuds configurés, et si vous voulez afficher les affectations des bits d'entrée ou de sortie. Les affectations peuvent être imprimées en cliquant sur le bouton Imprimer au bas de la fenêtre de dialogue.

la Liste Affectations est utile pour vérifier que vous avez configuré le nombre exact de bits d'entrée et de sortie et l'adresse correcte du noeud pour chaque noeud. Le logiciel Liste d'Affectation travaille à partir de l'actuel configuration C/MRI, si un noeud a été configuré, il sera sélectionnable dans le dialogue de la liste des affectations de C/MRI. Le tableau d'affectation contient une ligne pour chaque bit configuré d'entrée ou sortie. Chaque ligne contient aussi une adresse dans la colonne montrant quelle adresse utiliser pour chaque nom système C/MRI de JMRI . L'impression vide de la liste d'affectation pour chaque noeud fournit un document pratique à utiliser dans la détermination des affectations des bits d'entrée/sortie.

Numérotation utilisée dans les Noms Systèmes C/MRI

Les noms système C/MRI commencent par "C". Par exemple, "CS24" se réfère à la 24eme ligne d'entrée, c'est un "S" pour Sensor (Capteur), "CL35" se réfère à la 35ieme ligne de sortie , "L" pour Light ( lumière), et "CT38" se réfère à la 38ème ligne de sortie, un "T" pour Turnout (aiguillage)(tous pour un noeud avec l'adresse de 0).

Chaque noeud, entrées et sorties est numéroté séquentiellement à partir de 1, sans se soucier des types de cartes, ou du type de carte qui est dans ce connecteur de carte. Par exemple, si vous avez deux cartes d'entrée 24-bit, CS25 se réfère à l'entrée de première ligne sur la carte seconde entrée. Si vous avez deux cartes d'entrée 32-bit, CS25 se réfère à la ligne d'entrée 25e sur la carte première entrée.

Chaque SMINI, USIC ou SUSIC (noeud) a une adresse unique fixée par ses commutateurs d'adresses et est entrée lorsque vous avez configuré chaque noeud C/MRI ( voir ci-dessus). Les Capteurs et les aiguillages sur le premier noeud (adresse 0) sont numérotées de 1 à 999; Les capteurs et les branchements sur le deuxième noeud (adresse 1) sont numérotés 1001 à 1999 etc ; Notez que les adresses de noeud peuvent être séquentielles, mais ne sont pas requises pour être ainsi.

Par exemple:

  • Disons que vous avez une SMINI avec ses commutateurs adresse réglé sur "2". Toutes les entrées et les sorties sur ce noeud seront numérotées à partir de 2001.
    • CT2001 est la première broche de sortie
    • CT2048 est la dernière broche de sortie
    • CS2001 est la première broche d'entrée
    • CS2024 est la dernière broche d'entréee
    • Si vous avez une USIC avec ses commutateurs adresse réglé sur "1", elle aurra toutes les entrées et les sorties numérotés à partir de 1001. Si elle a trois cartes d'entrée 24-bit, et deux cartes de sortie 24-bit, leur adresse sera:
      • CT1001 est la première broche sur la première carte de sortie
      • CT1024 est la dernière broche sur la première carte de sortie
      • CT1025 est la première broche sur la 2ème carte de sortie
      • CT1048 est la dernière broche sur la 2ème carte sortie
      • CS1001 est la première broche sur la première carte d'entrée e
      • CS1024 est la dernière broche sur la première carte d'entrée
      • CS1025 est la première broche sur la 2ème carte entrée
      • CS1049 est la premiere broche sur la troisième carte d'entrée
      • CS1072 est la dernière broche sur la 3ème carte d'entré
      Notez que ce n'est pas dans n'importe quel ordre que les cartes sont installées. ça a été configuré lorsque vous avez mis en place le matériel. JMRI s'est dit quel type de carte est installé dans ce connecteur USIC lorsque vous définissez le noeud dans le dialogue de configuration C/MRI (voir ci-dessus).
    • vous avez un SUSIC avec son adresse commutateurs réglé sur "4", les entrées et les sorties seront numérotées à partir de 4001. Si elle a deux cartes entrées 32-bit et de sortie à deux 32-bit , leur adresse sera:
      • CT4001 est la première broche sur la première carte de sortie
      • CT4032 est la dernière broche sur la première carte de sortie
      • CT4033 est la première broche sur la 2ème carte de sortie
      • CT4064 est la dernière broche sur la 2ème carte de sortie
      • CS4001 est la première broche sur la première carte d'entrée
      • CS4032 est la dernière broche sur la première carte d'entrée
      • CS4033 est la première broche sur la 2ème carte d'entrée
      • CS4064 est la dernière broche sur la 2ème carte d'entrée

    Quand vous une information Matérielle dans la fenêtre Ajouter capteur, vous pouvez Saisir l'ID du Noeud, suivi par un":". Cette méthode peut aussi être utilisée pour l'adressage alternatif/étendu.
    Donc pour un capteur sur le noeud 2, broche 3 vous pouvez entrer la ligne suivante dans le champ d'adresse matérie: 2:3

    Pour résumer, les broches d'entrée et de sortie sont étiquetées de manière séquentielle au sein de chaque noeud C/MRI. Pour compléter l'adresse de bit, ajouter 1000 fois à l'adresse de station au numéro de la broche numéro. Les adresses de noeuds peuvent aller aussi haut que le matériel C/MRI le permet.

    Pour un guide facile des adresses de broches d'entrée et de sortie, sélectionnez Liste Affectations dans le menu pour accéder aux tables C/MRI des entrées et sorties affectées et libres pour chaque entrées et sorties disponibles pour chaque noeud. Chaque table a une ligne pour chaque broche incluant une colonne d'adresse montrant quelle est l'adresse à utiliser pour cette broche dans les noms système.

    Numérotation Complémentaire pour les Noms Système

    Un schéma de rechange pour la numérotation dans les noms système de C/MRI a été développé pour donner accès aux utilisateurs au nombre total de lignes autorisées à la conception de matériel C/MRI. Le système principal de numérotation ( décrites ci-dessus) permet l'accès à 999 lignes d'entrée et de sortie sur chaque noeuds. La conception de matériel C/MRI, toutefois, supporte beaucoup plus de bits pour les noeuds USIC et SUSIC. La plupart des utilisateurs JMRI n'auront jamais besoin de ce régime complémentaire, et doivent utiliser le système de numérotation principal.

    Le régime complémentaire de numérotation est similaire au régime principal de numérotation, sauf l'adresse du noeuds et les numéro de bits sont séparés par un "B", et les deux adresse de noeud et le numéro de bits peuvent aller à n'importe quelle valeur prise en charge par C/MRI. Par exemple, CS1B13 se réfère à la ligne d'entrée 13 d'un noeud avec l'adresse 1, et est équivalent à CS1013 du mécanisme principal de numérotation. Aussi CT2B1109 se réfère à la ligne de sortie 1109 d'un noeud avec l'adresse 2, et il n'y a pas d'équivalent dans le système principal de numérotation. Les utilisateurs peuvent utiliser indifféremment le schéma de numérotation pour les numéros de ligne jusqu'à 999, mais il doit utiliser le système de numérotation pour les numéros complémentaires pour les numéros de ligne supérieur à 999. Pour plus de facilité pour communiquer avec d'autres utilisateurs, l'utilisation du schéma de numérotation principale est recommandée, à moins que des bits supérieur à 999 doivent être adressés.

    Options de Commande d'un Aiguillage par C/MRI

    Les aiguillages peuvent être commandés en utilisant un ou deux bits de sortie. Lorsque l'aiguillage est créé en utilisant l'option Ajouter dans le tableau aiguillage, il est demandé à l'utilisateur si l'aiguillage doit être piloté par un ou deux bits de sortie.

    Si la sortie de commande 1 bit est sélectionnée, l'utilisateur doit sélectionner la commande d'état "stable" ou "pulsé". Si l'"état stable" est sélectionné, alors le bit de sortie est réglé "Off"pour DIRECT ("normal" dans les manuels C/MRI) ou "On "pour DéVIé ("inverse" dans les manuels C/MRI). Lorsque le bit de sortie est déterminé, JMRI compare l'état requis à l'état indiqué par la valeur actuelle du bit de sortie. Si ces états différent, alors le bit de sortie est fixé comme indiqué ci-dessus. Si ces états sont les mêmes, cet état est comparé à l'état indiqué par les rétro-signalisations de l'aiguillage. Si les états sont les mêmes, aucune mesure n'est prise, puisque l'aiguillage est déjà dans l'état requis. Si les états sont différents, l'aiguillage a été sans doute changé par quelque moyen distinct de JMRI. Afin de s'assurer que l'aiguillage est effectivement mis à l'état requis, le bit de sortie est d'abord modifié pour correspondre à l'état indiqué par les informations de l'aiguillage, puis une seconde plus tard il est changé à nouveau pour correspondre à l'état demandé. Ceci garantit un changement d'état pour les dispositifs de commande des aiguillages qui nécessitent un changement d'état pour déplacer actuellement l'aiguillage.

    Si une sortie avec 1 bit de commande pulsée est sélectionnée, le bit de sortie est "Off" lorsque rien ne se passe. Lorsque l'état DéVIé est demandée, cette demande est comparée à l'état connu de l'aiguillage (qui suit les rétro-signalisations de l'aiguillage). Si l'état connu indique que l'aiguillage est déjà dans l'état requis, rien n'est fait. Si l'état connu est différent de l'état requis, alors le bit est "pulsée". Une "pulse" se compose de bits étant mis à "On" pour une seconde, puis revient à "Off .

    Si la commande par deux bits de sortie est sélectionnée, le bit référencé dans le nom système d'aiguillage (voir ci-dessus) et le bit suivant dans la séquence sont utilisés pour contrîler l'aiguillage. Par exemple, si CT33 a deux bits de sorties de commande, les bits 33e et 34e sont utilisés pour commander l'aiguillage. Si la commande des deux bits de sorties est sélectionnée, l'utilisateur doit sélectionner la commande par état "stable" ou "pulsé". La Commande de l'état stable devrait être sélectionné pour les moteur d'aiguillage à décrochage, comme les Tortoises, si il est commandé selon la recommandation dans le manuel utilisateur version 3.0, page 3-12 de Chubb . Avec le contrîle de l'état d'équilibre, pour DIRECT, le premier bit est réglée sur "OFF" et le second bit est réglé sur "ON", pour DéVIé, l'états des bits sont inversé, c'est à dire, le premier bit est réglé sur "ON" et le second bit est réglé sur "OFF".

    Si la commande avec deux bits de sortie avec commande impulsionelle est demandée, les deux bits sont "Off" quand rien ne se passe. Lorsque DIRECT ou DéVIé est demandée, cette demande est comparée à l'état connu de l'aiguillage (qui suit les rétro-signalisations de l'aiguillage). Si l'état connu indique que l'aiguillage est déjà dans l'état requis, rien n'est fait. Si l'état connu est différent de l'état requis, alors le premier bit est pulsé si DIRECT est demandé, ou le second bit est pulsé si DéVIé est demandé. Dans les deux cas, une "impulsion" consiste en un créneau porté à "On" pendant une seconde, puis revient à la position "Off".

    Notez que d'avoir une commande deux bits de sortie, impose la création d'un aiguillage en utilisant le bouton "Ajouter" dans le Tableau Aiguillage.

    Enfin, l'option "inversé" peut être sélectionnée. Ce contrîle de la façon dont le matériel le CMRI met en oeuvre le "On " et "Off" utilisé dans le description ci-dessus. Normalement (l'option inverser n'est pas pas sélectionnée), "ON" se réfère à un "1" pour le matériel; pour la norme matériel C/MRI, tire la broche de sortie vers la masse et lui permet de recevoir du courant. "Off" correspond à un "0 "pour le matériel, en mettant la broche de sortie hors tension, et de le faire arrêter par manque de courant

    Lorsque "inverser" est sélectionné, "On " se traduit par un "0" envoyé au matériel, et "Off" se traduit par un "1" . Cela provoque la réaction du matériel avec la polarité opposée. .

    Câblage Signaux

    JMRI peut travailler avec tous les moyens populaires de câblage des signaux au matériel C/MRI (et il y en a beaucoup !) Pour plus d'informations sur la façon de configurer vos signaux pour le programme s'il vous plaît voir la page signaux C/MRIJ.

    C/MRI Diagnostiques

    JMRI supporte les deux procédures automatisées de diagnostique mentionnées au chapitre 6 du Manuel Utilisateur Version 3.0 de Chubb Bruce. Les diagnostiques sont utiles pour vérifier le bon fonctionnement de votre matériel C/MRI. Ces procédures automatisées sont contrîlées par une boîte de dialogue disponible en sélectionnant Exécuter Diagnostique, dans le menu CMRI. Le test Wraparound requiert un essai des câbles de bouclage, et le test de sortie nécessite une carte spéciale d'essai de sortie. Les deux dispositifs sont décrits dans la référence ci-dessus. Toutes les autres connexions au bit d'entrée ou de sortie sur la carte (s) à l'essai doivent être débranchées lorsque ces tests sont exécutés. Les diagnostics sont faciles à utiliser. Il suffit de suivre les instructions présentées dans le dialogue Exécution du Diagnostique C/MRI. Toutes les erreurs trouvées sont signalées dans la boîte d'état du dialogue. .

    L'utilisation d'adaptateurs USB-série

    La plupart des systèmes C/MRI utilisent des signaux électriques RS485 pour communiquer entre les noeuds et l'ordinateur. Il existe plusieurs façons de les générer:
    1. Si votre ordinateur est équipé d'un port série (RS232), vous pouvez utiliser une interface convertisseur RS232-RS485. Il y en a une que vous pouvez construire comme partie du système C/MRI, ou vous pouvez acheter un produit commercial.
    2. Si votre ordinateur possède un port USB, vous pouvez acheter un adaptateur commercial USB-vers RS485 et l'utiliser.
    3. Si votre ordinateur possède un port USB et vous avez un convertisseur RS232 à RS485 , vous pouvez installer un adaptateur USB-RS232 (parfois appelé un "convertisseur USB-série"), puis connectez la sortie RS232 de cet adaptateur à l' entrée RS232 du convertisseur RS232 à RS485. Notez que si vous utilisez le convertisseur Chubb RS232-RS485-, pour certains adaptateurs USB-RS232, il faudra que vous vous connectiez certains fils de commande RS232 qui ne sont pas traités par le convertisseur Chubb:
      • DSR - DTR (pins 4&6 sur le connecteur DB9)
      • RTS - CTS (pins 7&8 sur le connecteur DB9)
    Dans tous les cas, la ligne de communication finira par apparaître comme un port série sur votre ordinateur. Dans Windows, il s'agit d'un port COMn, dans d'autres ordinateurs que c'est un appareil de série nommée. Vous aurez à choisir celui qui convient lors de la configuration JMRI. .

    Exécution de JMRI lorsqu'il est déconnecté de votre système C/MRI

    JMRI scrute continuellement, le matériel C/MRI pour les changements d'état. Si un ou plusieurs noeuds C/MRI ne répondent pas, éventuellement leurs entrées (capteurs) sont mis à l'état INCONNU pour indiquer que JMRI a perdu le contact avec ces dispositifs sur le réseau.

    Bien que ce soit la bonne chose à faire quand vous êtes vraiment connecté au matériel et tenter de faire fonctionner le réseau, il peut l'obtenir de la manière où vous êtes en cours d'exécution JMRI sans vos connexions réseau. Par exemple,Vous pouvez le faire, travailler sur vos panneaux tout en étant loin du réseau, ou alors que le réseau doit être mis hors tension pour une raison quelconque.

    Pour répondre en utilisant JMRI sans une connexion active au réseau, dans le JMRI 2.3.2 une version connexion "C/MRI Simulateur" connexion a été mis à disposition dans les préférences.

    S'il vous plaît noter que ce n'est valable que pour les utilisateurs qui ont déjà un connexion de travail C/MRI déjà configurée. S'il vous plaît ne pas essayer d' utiliser le simulateur CMRI avant de configurer une connexion valide de matériel C/MRI, cela ne fonctionnera pas.

    Une fois que vous avez votre connexion C/MRI configurée, si votre matériel n'est pas disponible, vous pouvez simplement aller dans les préférences JMRI, sélectionnez "C/MRI Simulator", Enregistrer les préférences, quitter et redémarrer. Ne pas modifier d'autres paramètres !

    Lorsque le matériel de la C/MRI est à nouveau disponible, rendez-vous dans les préférences JMRI, sélectionnez "C/MRI de série", enregistrer les préférences, quitter et redémarrer.

    Plus d'infos

    Pour plus d'informations sur les C/MRI (y compris le Manuel de l'utilisateur C/MRI), s'il vous plaît voir les

    JLC entreprises site web, l' utilisateur C/MRI yahoo groupe, et le site Web Interfaces Easee.