JMRI provides powerful tools for working with your layout.

Layout Automation

JMRI can be used to automate parts of your layout, from simply controlling a crossing gate to running trains in the background.

Throttles Preferences

Throttle Pref pane

The Throttles Preferences pane is accessible from the Throttles submenus in Tools menu.
For best experience, the recommended settings are those illustrated above.

It is recommended to close all Throttle panes before applying a new set of Preferences, and then reopen them once new settings are applied or saved.

Use extended throttle

This setting will enable/disable all extended throttles features.

Set Controls transparent

Will set background of throttle internal windows transparent, or semi transparent.
This feature is known to work fine on OS X, but Linux and Windows to be worked on, totally varies depending on curent Java interface look'n feel (modifiable in JMRI main preferences)

Use Roster image as background

When a roster is selected, the image defined in its Media Panel will be loaded as a background for the throttle window.
When this option is enabled and the selected address is 0 or 3, a default image will be loaded.

Resize window to image size

When a background image is loaded for current throttle, will force the Throttle Window size to the one of that image.

Search Roster info when address entered

When an address is entered in the Address Panel, the JMRI Roster database will be searched for a matching roster entry (and will hence triggers options described above and bellow if they're enabled).

Automatic loading Throttle pane preferences when linked to Roster

When a Roster is selected, if a matching Throttle definition file exist, JMRI will automatically loads it.
These files are stored in <JMRI Preference Folder>/Throttle/XYZ.xml where XYZ in the Roster ID.
Using the Save menu entry from the File menu in a Throttle Window will create or update these files.

Ignore Throttle frame position

For old Throttle files that contain Throttle Window position in them, do as described.
Note: Throttle Windows position are now saved in the Throttles Layout backup files (not in the Throttles backup files anymore)

Hide undefined Roster function buttons

When a Roster is selected, the address panels buttons are initialized as defined in the Functions panel in DecoderPro. If this option is enabled, buttons not defined (no text) in PanelPro will be automatically hidden in the Function Panel.
Note: you can reset Function Buttons visibility in a Throttle Window by going to View Menu and clicking "Show all function buttons".

Enable Throttle toolbar

This option enables a Toolbar that will show in all Throttle Windows.