Throttles

Tools

JMRI provides powerful tools for working with your layout.

Layout Automation

JMRI can be used to automate parts of your layout, from simply controlling a crossing gate to running trains in the background.

Throttle Menus

File menu


Load throttle

This menu entry allows to load a Throttle window layout into the current Throttle Window; it will load inner windows properties, and Jynstruments if any.

Save current throttle

This menu entry allows to save the current Throttle window layout; it will save inner windows of the current throttle properties, and Jynstruments if any.
When a Roster entry is selected, that menu entry is automatically enabled. Using it will create (or update) a default Throttle file for that Roster entry in <JMRI Preferences Folder>/throttle/XYZ.xml where XYZ is the Roster ID.

Note that when saving a Throttle that is the default one for a Roster Entry, Function Buttons customization won't be saved in that file, they have to be exported to the Roster Entry (from the Edit menu, see below).

Save current throttle as...

Allows to save the current Throttle window layout using any file name and path. If this filename is not the default one for a Roster Entry, then Function Buttons customizations will be saved in that file.

Edit menu


Frame Properties

ThrottleWindowPreferences.png
Allows for editing current Throttle Window properties, particularly the Window title:
Note that if you enter text, it won't be visible unless one of the middle three modes is selected.

Reset Function Buttons

Reset the function buttons content to default and reset their visibility.
If a Roster is selected, default button content will be loaded from Roster entry; furthermore, if the matching preference is enabled, buttons undefined is the Roster entry will be hidden.

Export current throttles customization to roster

Push current Throttle window customizations to the Roster, in particular Function Buttons customizations. See Roster Functions Labels Pane.

View menu


The first part of the "View" menu displays a small menu of 3 items — by default, each with a check mark preceding the item. This corresponds to the 3 sub-windows (Address Panel, Function Panel, & Control Panel) that are part of the throttle window.

As each sub-window has a minimize and close buttons, if one gets closed down in error, this menu option allows you to restore the window again.

Another way to use this option is when using the features of the Throttles for decoders that are not associated with a Locomotive (such as a lighted passenger car or caboose or a Fred unit). In these cases, critical screen real estate can be saved by being able to disable (or close down) the Control Panel. Be a little creative with the window resizing, and you could have several of these custom Throttle windows in the same area as one single complete Throttle window would take up.

Show all function buttons

Note: this functionality was moved to "Reset Function Buttons" in the "Edit" menu

Get all current throttle components in bounds

Make sure that all inner windows of the current Throttle are inside the Throttle Window bounds.